use strict;
my $str = 'ðŸðŸŒ¼ðŸ‚ This is an example to show the #hash searching.All the terms containg #symbol will be found and you will get a #result ';
my $regex = qr/(^|\s)(#[a-z\d][\w-]*) /ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";