import Foundation
let pattern = ##"(^|\s)(#[a-z\d][\w-]*) "##
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"ðŸðŸŒ¼ðŸ‚ This is an example to show the #hash searching.All the terms containg #symbol will be found and you will get a #result "##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)