#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(^|\s)(#[a-z\d][\w-]*) "
Local $sString = "ðŸðŸŒ¼ðŸ‚ This is an example to show the #hash searching.All the terms containg #symbol will be found and you will get a #result "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)