package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(^|\s)(#[a-z\d][\w-]*) `)
var str = `ðŸðŸŒ¼ðŸ‚ This is an example to show the #hash searching.All the terms containg #symbol will be found and you will get a #result `
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}