re = /(^|\s)(#[a-z\d][\w-]*) /i
str = 'ðŸðŸŒ¼ðŸ‚ This is an example to show the #hash searching.All the terms containg #symbol will be found and you will get a #result '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result