# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\/?(\w+\\/)*//g;t' <<< "fileadmin/images/example/folder/dummy_001.jpg
fileadmin/images/example/dummy_002.png
/fileadmin/images/dummy_003.gif"