use strict;
my $str = 'fileadmin/images/example/folder/dummy_001.jpg
fileadmin/images/example/dummy_002.png
/fileadmin/images/dummy_003.gif';
my $regex = qr/\/?(\w+\/)*/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";