import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/?(\\w+\\/)*";
final String string = "fileadmin/images/example/folder/dummy_001.jpg\n"
+ "fileadmin/images/example/dummy_002.png\n"
+ "/fileadmin/images/dummy_003.gif";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}