package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`192\.168\.2[23]\.[0-9]{1,3}`)
var str = `192.168.22.101
192.168.23.15
192.168.24.123
192.168.22.1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}