import Foundation
let pattern = #"192\.168\.2[23]\.[0-9]{1,3}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
192.168.22.101
192.168.23.15
192.168.24.123
192.168.22.1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)