$re = '/192\.168\.2[23]\.[0-9]{1,3}/';
$str = '192.168.22.101
192.168.23.15
192.168.24.123
192.168.22.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);