re = /192\.168\.2[23]\.[0-9]{1,3}/
str = '192.168.22.101
192.168.23.15
192.168.24.123
192.168.22.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end