import re
regex = re.compile(r"192\.168\.2[23]\.[0-9]{1,3}")
test_str = ("192.168.22.101\n"
"192.168.23.15\n"
"192.168.24.123\n"
"192.168.22.1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")