# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^|(?<=\s))([a-zA-Z])[a-zA-Z]+\s*/$1/g;t' <<< "My new project 2015"