re = /(?:^|(?<=\s))([a-zA-Z])[a-zA-Z]+\s*/
str = 'My new project 2015'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result