const regex = /(?:^|(?<=\s))([a-zA-Z])[a-zA-Z]+\s*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|(?<=\\s))([a-zA-Z])[a-zA-Z]+\\s*', 'g')
const str = `My new project 2015`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);