using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|(?<=\s))([a-zA-Z])[a-zA-Z]+\s*";
string substitution = @"$1";
string input = @"My new project 2015";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}