use strict;
my $str = 'My new project 2015';
my $regex = qr/(?:^|(?<=\s))([a-zA-Z])[a-zA-Z]+\s*/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";