import Foundation
let pattern = #"(?:^|(?<=\s))([a-zA-Z])[a-zA-Z]+\s*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"My new project 2015"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)