$re = '/(?:^|(?<=\s))([a-zA-Z])[a-zA-Z]+\s*/';
$str = 'My new project 2015';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;