# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*?)(\[DLC\])(.*)$/$1$3$2/gm;t' <<< "Hello [DLC] World"