$re = '/^(.*?)(\[DLC\])(.*)$/m';
$str = 'Hello [DLC] World';
$subst = "$1$3$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;