use strict;
my $str = 'Hello [DLC] World';
my $regex = qr/^(.*?)(\[DLC\])(.*)$/mp;
my $subst = '$1$3$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";