re = /^(.*?)(\[DLC\])(.*)$/m
str = 'Hello [DLC] World'
subst = '$1$3$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result