import Foundation
let pattern = #"^(.*?)(\[DLC\])(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Hello [DLC] World"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$3$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)