const regex = /^(.*?)(\[DLC\])(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?)(\\[DLC\\])(.*)$', 'gm')
const str = `Hello [DLC] World`;
const subst = `$1$3$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);