#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?(?:100(?:\.00?)?|\d\d?(?:\.\d\d?)?)$"
Local $sString = "-0" & @CRLF & _
"-01" & @CRLF & _
"0.00" & @CRLF & _
"0.1" & @CRLF & _
"2" & @CRLF & _
"5" & @CRLF & _
"33" & @CRLF & _
"77" & @CRLF & _
"-99" & @CRLF & _
"-100.0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")