import re
regex = re.compile(r"^-?(?:100(?:\.00?)?|\d\d?(?:\.\d\d?)?)$", flags=re.MULTILINE)
test_str = ("-0\n"
"-01\n"
"0.00\n"
"0.1\n"
"2\n"
"5\n"
"33\n"
"77\n"
"-99\n"
"-100.0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")