using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^-?(?:100(?:\.00?)?|\d\d?(?:\.\d\d?)?)$";
string input = @"-0
-01
0.00
0.1
2
5
33
77
-99
-100.0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}