$re = '/^-?(?:100(?:\.00?)?|\d\d?(?:\.\d\d?)?)$/m';
$str = '-0
-01
0.00
0.1
2
5
33
77
-99
-100.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);