import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?(?:100(?:\\.00?)?|\\d\\d?(?:\\.\\d\\d?)?)$";
final String string = "-0\n"
+ "-01\n"
+ "0.00\n"
+ "0.1\n"
+ "2\n"
+ "5\n"
+ "33\n"
+ "77\n"
+ "-99\n"
+ "-100.0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}