re = /^-?(?:100(?:\.00?)?|\d\d?(?:\.\d\d?)?)$/m
str = '-0
-01
0.00
0.1
2
5
33
77
-99
-100.0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end