# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a.*?<\\/a>(*SKIP)(*F)|site/Stack Overflow/g;t' <<< "Right now, site is available at <a href=\"http://www.example.com/site\">site.com</a>"