// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<a.*?<\/a>(*SKIP)(*F)|site").unwrap();
let string = "Right now, site is available at <a href=\"http://www.example.com/site\">site.com</a>";
let substitution = "Stack Overflow";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}