re = /<a.*?<\/a>(*SKIP)(*F)|site/
str = 'Right now, site is available at <a href="http://www.example.com/site">site.com</a>'
subst = 'Stack Overflow'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result