using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.*?<\/a>(*SKIP)(*F)|site";
string substitution = @"Stack Overflow";
string input = @"Right now, site is available at <a href=""http://www.example.com/site"">site.com</a>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}