$re = '/<a.*?<\/a>(*SKIP)(*F)|site/';
$str = 'Right now, site is available at <a href="http://www.example.com/site">site.com</a>';
$subst = "Stack Overflow";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;