use strict;
my $str = 'Right now, site is available at <a href="http://www.example.com/site">site.com</a>';
my $regex = qr/<a.*?<\/a>(*SKIP)(*F)|site/p;
my $subst = 'Stack Overflow';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";