#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<a.*?<\/a>(*SKIP)(*F)|site"
Local $sString = "Right now, site is available at <a href="http://www.example.com/site">site.com</a>"
Local $sSubst = "Stack Overflow"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)