import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^:])(\\/{2,})";
final String string = "<a href=\"//google.com\"><img src=\"http://www.ebeyonds.com/sec.png\"></a>\n\n"
+ "<a href=\"https://host.org\"><img src=\"http://www.ebeyonds.com/sec.png\"></a>\n\n"
+ "<a href=\"http://www.ebeyonds.com/www.abc.com\"><img src=\"http://www.ebeyonds.com//www.abc.com\"></a>\n\n"
+ " <a href=\"mailto:chairman@edb.tradenetsl.lk\"><img src=\"http://www.ebeyonds.com//www.abc.com\"></a>\n\n"
+ "<link href=\"http://www.ebeyonds.com//a//styles.css\" rel=\"alternate stylesheet\" type=\"text/css\" />\n\n"
+ "<script type=\"text/javascript\" src=\"http://www.ebey\n\n\n\n"
+ "<a href=\"//google.com\"><img src=\"sec.png\"></a>\n"
+ " <a href=\"https://host.org\"><img src=\"sec.png\"></a>\n"
+ " <a href=\"www.abc.com\"><img src=\"/www.abc.com\"></a>\n"
+ " <a href=\"mailto:chairman@edb.tradenetsl.lk\"><img src=\"/www.abc.com\"></a>\n"
+ "<link href=\"/a//styles.css\" rel=\"alternate stylesheet\" type=\"text/css\" />\n"
+ "<script type=\"text/javascript\" src=\"./style.js\"></script>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}