// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([^:])(\/{2,})").unwrap();
let string = "<a href=\"//google.com\"><img src=\"http://www.ebeyonds.com/sec.png\"></a>
<a href=\"https://host.org\"><img src=\"http://www.ebeyonds.com/sec.png\"></a>
<a href=\"http://www.ebeyonds.com/www.abc.com\"><img src=\"http://www.ebeyonds.com//www.abc.com\"></a>
<a href=\"mailto:chairman@edb.tradenetsl.lk\"><img src=\"http://www.ebeyonds.com//www.abc.com\"></a>
<link href=\"http://www.ebeyonds.com//a//styles.css\" rel=\"alternate stylesheet\" type=\"text/css\" />
<script type=\"text/javascript\" src=\"http://www.ebey
<a href=\"//google.com\"><img src=\"sec.png\"></a>
<a href=\"https://host.org\"><img src=\"sec.png\"></a>
<a href=\"www.abc.com\"><img src=\"/www.abc.com\"></a>
<a href=\"mailto:chairman@edb.tradenetsl.lk\"><img src=\"/www.abc.com\"></a>
<link href=\"/a//styles.css\" rel=\"alternate stylesheet\" type=\"text/css\" />
<script type=\"text/javascript\" src=\"./style.js\"></script>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}