const regex = /([^:])(\/{2,})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^:])(\\\/{2,})', '')
const str = `<a href="//google.com"><img src="http://www.ebeyonds.com/sec.png"></a>
<a href="https://host.org"><img src="http://www.ebeyonds.com/sec.png"></a>
<a href="http://www.ebeyonds.com/www.abc.com"><img src="http://www.ebeyonds.com//www.abc.com"></a>
<a href="mailto:chairman@edb.tradenetsl.lk"><img src="http://www.ebeyonds.com//www.abc.com"></a>
<link href="http://www.ebeyonds.com//a//styles.css" rel="alternate stylesheet" type="text/css" />
<script type="text/javascript" src="http://www.ebey
<a href="//google.com"><img src="sec.png"></a>
<a href="https://host.org"><img src="sec.png"></a>
<a href="www.abc.com"><img src="/www.abc.com"></a>
<a href="mailto:chairman@edb.tradenetsl.lk"><img src="/www.abc.com"></a>
<link href="/a//styles.css" rel="alternate stylesheet" type="text/css" />
<script type="text/javascript" src="./style.js"></script>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}