# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([^:])(\/{2,})"
test_str = ("<a href=\"//google.com\"><img src=\"http://www.ebeyonds.com/sec.png\"></a>\n\n"
"<a href=\"https://host.org\"><img src=\"http://www.ebeyonds.com/sec.png\"></a>\n\n"
"<a href=\"http://www.ebeyonds.com/www.abc.com\"><img src=\"http://www.ebeyonds.com//www.abc.com\"></a>\n\n"
" <a href=\"mailto:chairman@edb.tradenetsl.lk\"><img src=\"http://www.ebeyonds.com//www.abc.com\"></a>\n\n"
"<link href=\"http://www.ebeyonds.com//a//styles.css\" rel=\"alternate stylesheet\" type=\"text/css\" />\n\n"
"<script type=\"text/javascript\" src=\"http://www.ebey\n\n\n\n"
"<a href=\"//google.com\"><img src=\"sec.png\"></a>\n"
" <a href=\"https://host.org\"><img src=\"sec.png\"></a>\n"
" <a href=\"www.abc.com\"><img src=\"/www.abc.com\"></a>\n"
" <a href=\"mailto:chairman@edb.tradenetsl.lk\"><img src=\"/www.abc.com\"></a>\n"
"<link href=\"/a//styles.css\" rel=\"alternate stylesheet\" type=\"text/css\" />\n"
"<script type=\"text/javascript\" src=\"./style.js\"></script>")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.