$re = '/([^:])(\/{2,})/';
$str = '<a href="//google.com"><img src="http://www.ebeyonds.com/sec.png"></a>
<a href="https://host.org"><img src="http://www.ebeyonds.com/sec.png"></a>
<a href="http://www.ebeyonds.com/www.abc.com"><img src="http://www.ebeyonds.com//www.abc.com"></a>
<a href="mailto:chairman@edb.tradenetsl.lk"><img src="http://www.ebeyonds.com//www.abc.com"></a>
<link href="http://www.ebeyonds.com//a//styles.css" rel="alternate stylesheet" type="text/css" />
<script type="text/javascript" src="http://www.ebey
<a href="//google.com"><img src="sec.png"></a>
<a href="https://host.org"><img src="sec.png"></a>
<a href="www.abc.com"><img src="/www.abc.com"></a>
<a href="mailto:chairman@edb.tradenetsl.lk"><img src="/www.abc.com"></a>
<link href="/a//styles.css" rel="alternate stylesheet" type="text/css" />
<script type="text/javascript" src="./style.js"></script>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);