#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([A-Z]{1,3}-[0-9]{4}.[0-9]{2}[A-Z]{1,3})"
Local $sString = "http://www.withagen-attractieverhuur.nl/TipProduct/SP-2008.05A/Circus%20overdekt/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")