import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z]{1,3}-[0-9]{4}.[0-9]{2}[A-Z]{1,3})";
final String string = "http://www.withagen-attractieverhuur.nl/TipProduct/SP-2008.05A/Circus%20overdekt/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}