// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([A-Z]{1,3}-[0-9]{4}.[0-9]{2}[A-Z]{1,3})").unwrap();
let string = "http://www.withagen-attractieverhuur.nl/TipProduct/SP-2008.05A/Circus%20overdekt/";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}