import Foundation
let pattern = #"([A-Z]{1,3}-[0-9]{4}.[0-9]{2}[A-Z]{1,3})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"http://www.withagen-attractieverhuur.nl/TipProduct/SP-2008.05A/Circus%20overdekt/"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
    let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
    print(result)
} else {
    print("No matches were found.")
}