re = /([A-Z]{1,3}-[0-9]{4}.[0-9]{2}[A-Z]{1,3})/
str = 'http://www.withagen-attractieverhuur.nl/TipProduct/SP-2008.05A/Circus%20overdekt/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end