using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z]{1,3}-[0-9]{4}.[0-9]{2}[A-Z]{1,3})";
string input = @"http://www.withagen-attractieverhuur.nl/TipProduct/SP-2008.05A/Circus%20overdekt/";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}